Package: python-oslo.messaging / 5.10.0-2

Metadata

Package Version Patches format
python-oslo.messaging 5.10.0-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
try using future absolute import.patch | (download)

oslo_messaging/tests/__init__.py | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 using absolute_import
fixes monkey_patch call.patch | (download)

oslo_messaging/tests/__init__.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fixes monkey_patch() call
avoid pifpaf.patch | (download)

oslo_messaging/tests/functional/test_rabbitmq.py | 5 4 + 1 - 0 !
1 file changed, 4 insertions(+), 1 deletion(-)

 avoid use of pifpaf
 pifpaf is only used for directly control of RabbitMQ in upstream
 functional testing, and is not packaged in Debian or Ubuntu.
 .
 Don't error on import if its not found.