Package: python-padme / 1.1.1-3

Metadata

Package Version Patches format
python-padme 1.1.1-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
001 old unittest2 support | (download)

padme/tests.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 add support for old unittest2 version (0.5.1)

 Upstream relies on more recent version of unittest2 that has support for the
 'assertRaisesRegex' method. Fortunately this method is a simple alias of
 'assertRaisesRegexp' (with extra 'p' at the end). Since the future of
 unittest2 in Debian is uncertain this intermediate trivial patch can be used
 to have working and tested version of Padme

improve compatiblity with mock | (download)

padme/tests.py | 5 4 + 1 - 0 !
1 file changed, 4 insertions(+), 1 deletion(-)

 <short summary of the patch>

 This patch fixes a build issue that started to occur as upstream mock has
 re-organized its internal layout. The issue is that padme needs to patch (fix)
 bugs in mock that are present on certain versions (especially in released
 versions of python that have broken unittest.mock) and the patching code does
 mess with some of the mock internals.