Package: python-setuptools / 33.1.1-1

sorted-requires.diff Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
Index: b/setuptools/command/egg_info.py
===================================================================
--- a/setuptools/command/egg_info.py
+++ b/setuptools/command/egg_info.py
@@ -617,7 +617,7 @@ def warn_depends_obsolete(cmd, basename,
 def _write_requirements(stream, reqs):
     lines = yield_lines(reqs or ())
     append_cr = lambda line: line + '\n'
-    lines = map(append_cr, lines)
+    lines = map(append_cr, sorted(lines))
     stream.writelines(lines)