Package: python-swiftclient / 1:3.1.0-3~bpo8+1

Metadata

Package Version Patches format
python-swiftclient 1:3.1.0-3~bpo8+1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
Require_futures_only_for_Python_2.patch | (download)

requirements.txt | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 [patch] installs futures only for python 2.7 and 2.6

The futures library is native to python 3 and it doesn't
have to be installed from pypi.

If the futures library is installed, it can cause issues when used.

Changes the futures' library requirement to match the one in
global requirements. [1]

[1] https://github.com/openstack/requirements/blob/master/global-requirements.txt

Bug: #1628107