Package: qt4-x11 / 4:4.8.7+dfsg-18

no_libicu_message.diff Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Author: Pino Toscano <pino@debian.org>
Description: Disable the warnings about not being able to dlopen ICU libraries.
 Most of the applications don't need ICU-based functions for locale-aware
 string upper- and lower-casing and comparison. If not present, Qt will use the
 own ways (i.e. those used also in Qt < 4.8).
Last-Update: 2012-05-21
Forwarded: not-needed

--- a/src/corelib/tools/qlocale_icu.cpp
+++ b/src/corelib/tools/qlocale_icu.cpp
@@ -88,7 +88,9 @@ bool qt_initIcu(const QString &localeStr
         QLibrary lib(QLatin1String("icui18n"), QLatin1String(U_ICU_VERSION_SHORT));
         lib.setLoadHints(QLibrary::ImprovedSearchHeuristics);
         if (!lib.load()) {
+#if 0
             qWarning() << "Unable to load library icui18n" << lib.errorString();
+#endif
             status = ErrorLoading;
             return false;
         }
@@ -118,7 +120,9 @@ bool qt_initIcu(const QString &localeStr
         QLibrary ucLib(QLatin1String("icuuc"), QLatin1String(U_ICU_VERSION_SHORT));
         ucLib.setLoadHints(QLibrary::ImprovedSearchHeuristics);
         if (!ucLib.load()) {
+#if 0
             qWarning() << "Unable to load library icuuc" << ucLib.errorString();
+#endif
             status = ErrorLoading;
             return false;
         }