Package: rabbitmq-server / 3.8.9-3

Metadata

Package Version Patches format
rabbitmq-server 3.8.9-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
lets use python3 not python binary.patch | (download)

deps/amqp10_common/codegen.py | 2 1 + 1 - 0 !
deps/amqp10_common/development.post.mk | 2 1 + 1 - 0 !
deps/rabbit_common/codegen.py | 2 1 + 1 - 0 !
deps/rabbit_common/development.post.mk | 2 1 + 1 - 0 !
deps/rabbitmq_auth_backend_http/examples/rabbitmq_auth_backend_django/manage.py | 2 1 + 1 - 0 !
deps/rabbitmq_auth_backend_http/examples/rabbitmq_auth_backend_django/start.sh | 4 2 + 2 - 0 !
deps/rabbitmq_consistent_hash_exchange/examples/python/example1.py | 2 1 + 1 - 0 !
deps/rabbitmq_consistent_hash_exchange/examples/python/example2.py | 2 1 + 1 - 0 !
deps/rabbitmq_consistent_hash_exchange/examples/python/example3.py | 2 1 + 1 - 0 !
deps/rabbitmq_trust_store/examples/rabbitmq_trust_store_django/manage.py | 2 1 + 1 - 0 !
10 files changed, 11 insertions(+), 11 deletions(-)

 using /usr/bin/python3, not just python
rabbitmq dist.mk.patch | (download)

deps/rabbit_common/mk/rabbitmq-dist.mk | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 make 4.3 compatibility change
Upstream_PR2965_fixing_rabbitmqctl_parsing | (download)

deps/rabbit/src/rabbit_disk_monitor.erl | 4 3 + 1 - 0 !
deps/rabbitmq_cli/lib/rabbitmq/cli/core/memory.ex | 6 6 + 0 - 0 !
2 files changed, 9 insertions(+), 1 deletion(-)

 fix incorrect parsing of vm_memory_high_watermark
 Upstream bug:
 https://github.com/rabbitmq/rabbitmq-server/issues/2964