Package: rails / 2:4.1.8-1

Metadata

Package Version Patches format
rails 2:4.1.8-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
be carefull with that bundler.patch | (download)

railties/lib/rails/generators/app_base.rb | 6 2 + 4 - 0 !
1 file changed, 2 insertions(+), 4 deletions(-)

 be careful with that bundler
 on Debian, Rails must preferably use Debian packages, while not stopping the
 users to get stuff from Rubygems if they want.
 .
 This way, when creating a new application, we run `bundle install --local`
 instead of `bundle install`, to make sure bundler does not download anything
 from Rubygems. That's not because I don't like Rubygems, but because
 everything the user will need to run this new app (sqlite3, sass-rails,
 coffee-rails) is already installed by means of Debian packages. If the user
 does want to use Rubygems packages after that, she will just edit the Gemfile,
 run `bundle install`, and bundler will do its thing as usual.
 .
 This is patch is most probably Debian-specific.