Package: rails / 2:6.0.3.5+dfsg-1

0002-disable-uglify-in-activestorage-rollup-config-js.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
Description: rollup-plugin-uglify is not packaged, hence disabling it.

--- a/activestorage/rollup.config.js
+++ b/activestorage/rollup.config.js
@@ -1,16 +1,16 @@
-import resolve from "rollup-plugin-node-resolve"
-import commonjs from "rollup-plugin-commonjs"
-import babel from "rollup-plugin-babel"
-import uglify from "rollup-plugin-uglify"
+import resolve from "@rollup/plugin-node-resolve"
+import commonjs from "@rollup/plugin-commonjs"
+import babel from "@rollup/plugin-babel"
+//import uglify from "rollup-plugin-uglify"
 
-const uglifyOptions = {
+/*const uglifyOptions = {
   mangle: false,
   compress: false,
   output: {
     beautify: true,
     indent_level: 2
   }
-}
+}*/
 
 export default {
   input: "app/javascript/activestorage/index.js",
@@ -20,9 +20,9 @@
     name: "ActiveStorage"
   },
   plugins: [
-    resolve(),
+    resolve({moduleDirectories: ['../debian/node_modules']}),
     commonjs(),
-    babel(),
-    uglify(uglifyOptions)
+    babel({babelHelpers: 'external'})
+//    uglify(uglifyOptions)
   ]
 }