Package: rake / 0.9.2.2-4

0001-remove_rubygems.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
From c6408410db046a22f0a8157e04cb5cb76ac5e32d Mon Sep 17 00:00:00 2001
From: Antonio Terceiro <terceiro@debian.org>
Date: Sat, 19 Nov 2011 18:06:57 -0200
Subject: [PATCH] Remove `require 'rubygems'`

---
 bin/rake             |    6 ------
 lib/rake/rdoctask.rb |    5 +----
 test/helper.rb       |    5 -----
 3 files changed, 1 insertions(+), 15 deletions(-)

diff --git a/bin/rake b/bin/rake
index 4e0bbb7..f1ac568 100755
--- a/bin/rake
+++ b/bin/rake
@@ -22,12 +22,6 @@
 # IN THE SOFTWARE.
 #++
 
-begin
-  require 'rubygems'
-  gem 'rake'
-rescue LoadError
-end
-
 require 'rake'
 
 Rake.application.run
diff --git a/lib/rake/rdoctask.rb b/lib/rake/rdoctask.rb
index b6ae224..f8d30a9 100644
--- a/lib/rake/rdoctask.rb
+++ b/lib/rake/rdoctask.rb
@@ -4,13 +4,10 @@ if Rake.application
   Rake.application.deprecate('require \'rake/rdoctask\'', 'require \'rdoc/task\' (in RDoc 2.4.2+)', __FILE__)
 end
 
-require 'rubygems'
-
 begin
-  gem 'rdoc'
   require 'rdoc'
   require 'rdoc/task'
-rescue LoadError, Gem::LoadError
+rescue LoadError
 end
 
 # :stopdoc:
diff --git a/test/helper.rb b/test/helper.rb
index 65443fc..0828739 100644
--- a/test/helper.rb
+++ b/test/helper.rb
@@ -1,10 +1,5 @@
 require 'rubygems'
 
-begin
-  gem 'minitest'
-rescue Gem::LoadError
-end
-
 require 'minitest/autorun'
 require 'rake'
 require 'tmpdir'
-- 
1.7.7.3