Package: roundcube / 1.2.3+dfsg.1-4+deb9u3

Metadata

Package Version Patches format
roundcube 1.2.3+dfsg.1-4+deb9u3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
dbconfig common_support.patch | (download)

config/config.inc.php.sample | 9 2 + 7 - 0 !
1 file changed, 2 insertions(+), 7 deletions(-)

---
debianize config.patch | (download)

config/config.inc.php.sample | 8 6 + 2 - 0 !
1 file changed, 6 insertions(+), 2 deletions(-)

---
correct_install_path.patch | (download)

program/include/iniset.php | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
use_pspell.patch | (download)

config/defaults.inc.php | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

---
loginbox size.patch | (download)

skins/classic/common.css | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
default charset utf8.patch | (download)

config/defaults.inc.php | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
debianize_password_plugin.patch | (download)

plugins/password/README | 11 7 + 4 - 0 !
plugins/password/helpers/chgsaslpasswd.c | 2 1 + 1 - 0 !
plugins/password/helpers/chgvirtualminpasswd.c | 2 1 + 1 - 0 !
3 files changed, 9 insertions(+), 6 deletions(-)

 specify debian path and group names in password plugin
map sqlite3 to sqlite.patch | (download)

program/lib/Roundcube/rcube_db.php | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

---
update_script.patch | (download)

bin/update.sh | 49 33 + 16 - 0 !
program/include/iniset.php | 4 4 + 0 - 0 !
program/include/rcmail_install.php | 31 28 + 3 - 0 !
3 files changed, 65 insertions(+), 19 deletions(-)

---
use embedded jquery for http authentication.patch | (download)

plugins/http_authentication/logout.html | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 avoid fetching jquery from google, use the embedded one
 This page is also just an example. The user is expected to provide its own page.

update_composer.patch | (download)

composer.json-dist | 18 8 + 10 - 0 !
1 file changed, 8 insertions(+), 10 deletions(-)

 update php pear dependecies
 The current dependencies that are published by upstream are too
 conservative.
 * So replace ~ (that only allows minor versions changes) with >= as documented
 in the INSTALL file.
 * delete dependency to net_idna2, that is only needed for PHP < 5.3
   (idn_to_utf8 and idn_to_ascii)
Set INSTALL_PATH to var lib roundcube in bin cleandb.patch | (download)

bin/cleandb.sh | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 [patch] set install_path to /var/lib/roundcube/ in bin/cleandb.sh

Cf. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824676#20

CVE 2017 6820.patch | (download)

program/lib/Roundcube/rcube_utils.php | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

---
CVE 2017 8114.patch | (download)

plugins/password/drivers/sasl.php | 2 1 + 1 - 0 !
plugins/password/drivers/virtualmin.php | 6 3 + 3 - 0 !
2 files changed, 4 insertions(+), 4 deletions(-)

---
CVE 2017 16651.patch | (download)

plugins/database_attachments/database_attachments.php | 7 6 + 1 - 0 !
plugins/filesystem_attachments/filesystem_attachments.php | 47 44 + 3 - 0 !
program/include/rcmail.php | 5 3 + 2 - 0 !
3 files changed, 53 insertions(+), 6 deletions(-)

---
CVE 2018 9846.patch | (download)

plugins/archive/archive.php | 6 4 + 2 - 0 !
plugins/managesieve/managesieve.php | 4 2 + 2 - 0 !
plugins/markasjunk/markasjunk.php | 9 6 + 3 - 0 !
program/lib/Roundcube/rcube_imap_generic.php | 10 6 + 4 - 0 !
4 files changed, 18 insertions(+), 11 deletions(-)

---
CVE 2018 1000071.patch | (download)

plugins/enigma/README | 15 13 + 2 - 0 !
plugins/enigma/config.inc.php.dist | 4 2 + 2 - 0 !
plugins/enigma/home/.htaccess | 7 0 + 7 - 0 !
plugins/enigma/lib/enigma_driver_gnupg.php | 2 1 + 1 - 0 !
4 files changed, 16 insertions(+), 12 deletions(-)

---
CVE 2018 19206.patch | (download)

program/steps/mail/func.inc | 5 3 + 2 - 0 !
1 file changed, 3 insertions(+), 2 deletions(-)

---