Package: rpm / 4.14.2.1+dfsg1-1

Metadata

Package Version Patches format
rpm 4.14.2.1+dfsg1-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
map populate.patch | (download)

tools/sepdebugcrcfix.c | 6 5 + 1 - 0 !
1 file changed, 5 insertions(+), 1 deletion(-)

 fix compation on platforms without map_populate
bashism.patch | (download)

scripts/check-rpaths | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 do not use bashism for gettext
  There are no translations anyway...
lua compat.patch | (download)

lib/rpmliblua.c | 1 1 + 0 - 0 !
luaext/lposix.c | 1 1 + 0 - 0 !
luaext/lrexlib.c | 1 1 + 0 - 0 !
rpmio/rpmlua.c | 1 1 + 0 - 0 !
4 files changed, 4 insertions(+)

 avoid undefined functions with lua 5.2
installplatform verbose.patch | (download)

installplatform | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 verbose installplatform
    Just make installplatform to ease debugging problems with creatin platform files.

rpmdb in home.patch | (download)

macros.in | 4 3 + 1 - 0 !
1 file changed, 3 insertions(+), 1 deletion(-)

 move default rpmdb path to user home
debian disable rpm.patch | (download)

configure.ac | 2 2 + 0 - 0 !
lib/poptI.c | 5 5 + 0 - 0 !
lib/rpmprob.h | 1 1 + 0 - 0 !
rpmqv.c | 8 8 + 0 - 0 !
4 files changed, 16 insertions(+)

 rpm is not default package manager on debian
 In Debian, rpm should be used to install packages, but rather as a tool to
 work with rpm packages or as a helper in alien. Because of this we protect
 complain, when user tries to install a package. This warning can be hidden 
 by --force-debian.
fix directories.patch | (download)

doc/manual/builddependencies | 2 1 + 1 - 0 !
macros.in | 2 1 + 1 - 0 !
platform.in | 2 1 + 1 - 0 !
3 files changed, 3 insertions(+), 3 deletions(-)

 fix installation directories
 - Do not install rpm to /bin/.
 - Setup default directories so that source RPMs rebuilt on Debian get
   the right directories and also that builds occur in /usr/src/rpm
 - Fix statedir and init.d patch
tempfile.patch | (download)

scripts/vpkg-provides.sh | 24 12 + 12 - 0 !
1 file changed, 12 insertions(+), 12 deletions(-)

 use the debian standard (and safe) mechanism of generating temporary files
autogen cleanup.patch | (download)

autogen.sh | 24 24 + 0 - 0 !
1 file changed, 24 insertions(+)

 delete some crap after running autogen.
lua libname.patch | (download)

configure.ac | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 in debian, lua library is called lua5.2.
rpm 4.10.90 rpmlib filesystem check.patch | (download)

lib/depends.c | 107 106 + 1 - 0 !
1 file changed, 106 insertions(+), 1 deletion(-)

 add fedora compatible rpm builtin provides