Package: ruby-autoprefixer-rails / 8.6.5+dfsg-3

remove-git-in-gemspec.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
--- a/autoprefixer-rails.gemspec
+++ b/autoprefixer-rails.gemspec
@@ -8,8 +8,8 @@
   s.summary     = 'Parse CSS and add vendor prefixes to CSS rules using ' +
                   'values from the Can I Use website.'
 
-  s.files            = `git ls-files`.split("\n")
-  s.test_files       = `git ls-files -- {spec}/*`.split("\n")
+  s.files            = Dir.glob("**/*").select {|v| v !~ /^debian/}
+  s.test_files       = s.files.select {|v| v =~ /^(test|spec|features)/}
   s.extra_rdoc_files = ['README.md', 'LICENSE', 'CHANGELOG.md']
   s.require_path     = 'lib'
   s.required_ruby_version = '>= 2.0'