Package: ruby-aws-sdk / 1.67.0-2

Metadata

Package Version Patches format
ruby-aws-sdk 1.67.0-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
use correct path for autoload | (download)

lib/aws/core.rb | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 use the correct path to autoload libs

use correct path for bundled files | (download)

lib/aws/core.rb | 4 3 + 1 - 0 !
lib/aws/core/client.rb | 4 2 + 2 - 0 !
lib/aws/core/configuration.rb | 2 1 + 1 - 0 !
lib/aws/core/endpoints.rb | 2 1 + 1 - 0 !
4 files changed, 7 insertions(+), 5 deletions(-)

 use the correct path to load the blunded files

maintain imports backwards compatibility | (download)

lib/aws-sdk.rb | 7 7 + 0 - 0 !
1 file changed, 7 insertions(+)

 maintain backwards compatibility with the old ruby require files.
  Ruby requires filenames have changed with the new released aws sdk version.
  Until is packaged, just maintain backwards compatibility adding this old
  one require file.

relax json requirement | (download)

aws-sdk-v1.gemspec | 6 3 + 3 - 0 !
1 file changed, 3 insertions(+), 3 deletions(-)

 relax the required version of json