Package: ruby-capybara / 2.2.1-1

0003-Inhibit-tests-that-needs-more-than-one-driver.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
From: =?utf-8?q?J=C3=A9r=C3=A9my_Bobbio?= <lunar@debian.org>
Date: Fri, 22 Mar 2013 09:12:31 +0000
Subject: Inhibit tests that needs more than one driver

As the :selenium driver is deactivated, there's only one driver left currently
(:rack_test). This means we have to skip tests that needs more than one driver.
---
 spec/dsl_spec.rb |    2 ++
 1 file changed, 2 insertions(+)

diff --git a/spec/dsl_spec.rb b/spec/dsl_spec.rb
index cce248d..b4e6286 100644
--- a/spec/dsl_spec.rb
+++ b/spec/dsl_spec.rb
@@ -157,12 +157,14 @@ describe Capybara::DSL do
     end
 
     it "should change with the current driver" do
+      pending 'waiting to have ruby-capybara-webkit or ruby-selenium-driver in Debian'
       Capybara.current_session.mode.should == :rack_test
       Capybara.current_driver = :selenium
       Capybara.current_session.mode.should == :selenium
     end
 
     it "should be persistent even across driver changes" do
+      pending 'waiting to have for ruby-capybara-webkit or ruby-selenium-driver in Debian'
       object_id = Capybara.current_session.object_id
       Capybara.current_session.object_id.should == object_id
       Capybara.current_driver = :selenium