Package: ruby-dep-selector / 1.0.3-2

Metadata

Package Version Patches format
ruby-dep-selector 1.0.3-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Do not require dep selector libgecode.patch | (download)

ext/dep_gecode/extconf.rb | 10 4 + 6 - 0 !
1 file changed, 4 insertions(+), 6 deletions(-)

 do not require dep-selector-libgecode


0002 Port to libgecode 4.0 Closes 710104.patch | (download)

ext/dep_gecode/dep_selector_to_gecode.cpp | 43 22 + 21 - 0 !
ext/dep_gecode/dep_selector_to_gecode.h | 2 1 + 1 - 0 !
2 files changed, 23 insertions(+), 22 deletions(-)

 port to libgecode >= 4.0 (closes: #710104)

* Port to libgecode >= 4.0 (Closes: #710104)
  - Restart class has been renamed to RBS which needs an Engine (chose DFS)
  - instances of RBS need a Search::Cutoff (arbitraly chose Geometric)
  - variable selection are now functions and need brackets
  - statistics about memory are not available in gecode (by default)

0003 Do not set rpath.patch | (download)

ext/dep_gecode/extconf.rb | 21 0 + 21 - 0 !
1 file changed, 21 deletions(-)

 do not set rpath


0004 Make it solve 2.0 compatible.patch | (download)

spec/solve_integration_spec.rb | 24 7 + 17 - 0 !
1 file changed, 7 insertions(+), 17 deletions(-)

 make it solve 2.0 compatible


0005 Make tests rspec3 compatible.patch | (download)

spec/dep_gecode_spec.rb | 2 1 + 1 - 0 !
spec/dep_selector/dependency_graph_spec.rb | 4 2 + 2 - 0 !
spec/dep_selector/error_reporter/simple_tree_traverser_spec.rb | 4 2 + 2 - 0 !
3 files changed, 5 insertions(+), 5 deletions(-)

 make tests rspec3 compatible


0006 Search for dep_gecode.so in vendorarchdir.patch | (download)

lib/dep_selector/dep_gecode.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 search for dep_gecode.so in vendorarchdir