Package: ruby-dep-selector / 1.0.3-2

0001-Do-not-require-dep-selector-libgecode.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
From: Hleb Valoshka <375gnu@gmail.com>
Date: Thu, 25 Jun 2015 11:55:08 +0300
Subject: Do not require dep-selector-libgecode

---
 ext/dep_gecode/extconf.rb | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/ext/dep_gecode/extconf.rb b/ext/dep_gecode/extconf.rb
index d14b856..208054b 100644
--- a/ext/dep_gecode/extconf.rb
+++ b/ext/dep_gecode/extconf.rb
@@ -24,10 +24,9 @@ if !defined?(RUBY_ENGINE) || RUBY_ENGINE == 'ruby' || RUBY_ENGINE == 'rbx'
   # ./configure --with-architectures=i386,x86_64
   # to work properly here.
   require 'mkmf'
-  require 'dep-selector-libgecode'
 
-  opt_path = DepSelectorLibgecode.opt_path
-  include_path = DepSelectorLibgecode.include_path
+  opt_path = "/usr/lib/#{`dpkg-architecture -qDEB_TARGET_MULTIARCH`}"
+  include_path = '/usr/include'
   if find_library("gecodesupport", nil, opt_path)
 
     # Ruby sometimes has a blank RPATHFLAG, even though it's on a system that
@@ -130,9 +129,8 @@ else # JRUBY
   incflags = "-I."
   libpath = "-L."
 
-  require 'dep-selector-libgecode'
-  opt_path = DepSelectorLibgecode.opt_path
-  include_path = DepSelectorLibgecode.include_path
+  opt_path = "/usr/lib/#{`dpkg-architecture -qDEB_TARGET_MULTIARCH`}"
+  include_path = '/usr/include'
   libpath << " -L#{opt_path}"
 
   # On MRI, RbConfig::CONFIG["RPATHFLAG"] == "" when using clang/llvm, but this