Package: ruby-factory-bot / 4.11.1-1

Metadata

Package Version Patches format
ruby-factory-bot 4.11.1-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0002 remove simplecov.patch | (download)

spec/spec_helper.rb | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 remove simplecov usage

Upstream uses simplecov to check the test coverage. This is unneeded if
building the package for Debian, accordingly, remove it.
0001 no git in gemspec.patch | (download)

factory_bot.gemspec | 4 1 + 3 - 0 !
1 file changed, 1 insertion(+), 3 deletions(-)

 don't use git in gemspec

Don't use git in gemspec, otherwise, the gemspec file is not found.
This makes dependency resolution check fail.
0004 Fix failing tests with rails 5.2.patch | (download)

spec/spec_helper.rb | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 fix failing tests with rails 5.2

It is still working with rails 4.2