Package: ruby-faraday / 1.1.0-6~bpo10+1

Metadata

Package Version Patches format
ruby-faraday 1.1.0-6~bpo10+1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
skip test failure on warning.patch | (download)

script/test | 12 0 + 12 - 0 !
1 file changed, 12 deletions(-)

 skip failure of tests on warning
001_remove bundler.patch | (download)

script/test | 6 3 + 3 - 0 !
1 file changed, 3 insertions(+), 3 deletions(-)

 we don't need rubygems or bundler
require faraday.patch | (download)

spec/spec_helper.rb | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

---
remove coveralls.patch | (download)

spec/spec_helper.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
skip test failing in ubuntu.patch | (download)

spec/faraday/connection_spec.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 skip test failing in ubuntu autopkgtest environment

The "does not accept uppercase env" test in connection_spec.rb tries to
set the HTTP_PROXY variable (uppercase) which should not work (nil is
expected). However, even if the test does not set the http_proxy var
(lower case) the Ubuntu autopkgtest environment sets this var to point
to squid.internal, which causes a test failure.