Package: ruby-flexmock / 2.3.6-7

Metadata

Package Version Patches format
ruby-flexmock 2.3.6-7 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 gemspec skip git usage.patch | (download)

flexmock.gemspec | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 gemspec: skip git usage


0002 gemspec don t assume lib exists.patch | (download)

flexmock.gemspec | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 gemspec: don't assume lib/ exists

This fixes running the test suite under autopkgtest

0003 Fix compatibility with Ruby 3.0.patch | (download)

lib/flexmock/composite_expectation.rb | 4 2 + 2 - 0 !
test/partial_mock_test.rb | 3 2 + 1 - 0 !
test/test_helper.rb | 2 1 + 1 - 0 !
3 files changed, 5 insertions(+), 4 deletions(-)

 patch to support ruby 3.0

- Use binding.source_location for test
- Properly accept argument and keywords
- Relax error message on test a bit

Kudos and thanks to the Fedora project.