Package: ruby-gettext / 3.0.2-2~bpo70+1

Metadata

Package Version Patches format
ruby-gettext 3.0.2-2~bpo70+1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Properly handle a closed stdin when prompting in msg.patch | (download)

lib/gettext/tools/msginit.rb | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 properly handle a closed stdin when prompting in msginit


0002 Make test unit notify and test unit rr optional to r.patch | (download)

test/run-test.rb | 16 14 + 2 - 0 !
1 file changed, 14 insertions(+), 2 deletions(-)

 make test-unit-notify and test-unit-rr optional to run the tests


0003 Do not use Bundler in Rakefile.patch | (download)

Rakefile | 12 1 + 11 - 0 !
1 file changed, 1 insertion(+), 11 deletions(-)

 do not use bundler in rakefile


0004 Use system racc in Rakefile.patch | (download)

Rakefile | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use system racc in rakefile


0005 Restore compatibility with Ruby 1.8.patch | (download)

lib/gettext/core_ext/iconv.rb | 110 110 + 0 - 0 !
lib/gettext/core_ext/string.rb | 91 91 + 0 - 0 !
lib/gettext/locale_path.rb | 1 1 + 0 - 0 !
lib/gettext/mo.rb | 54 37 + 17 - 0 !
lib/gettext/tools/parser/erb.rb | 16 9 + 7 - 0 !
lib/gettext/tools/parser/ruby.rb | 7 5 + 2 - 0 !
test/gettext-test-utils.rb | 23 23 + 0 - 0 !
test/test_parser.rb | 2 2 + 0 - 0 !
test/test_po_parser.rb | 4 4 + 0 - 0 !
test/tools/parser/test_ruby.rb | 2 2 + 0 - 0 !
test/tools/test_xgettext.rb | 24 15 + 9 - 0 !
11 files changed, 299 insertions(+), 35 deletions(-)

 restore compatibility with ruby 1.8


0006 Add missing require in lib gettext tools xgettext.rb.patch | (download)

lib/gettext/tools/xgettext.rb | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 add missing require in lib/gettext/tools/xgettext.rb

GetText::Tools::XGetText.parse uses GetText::PO, so the later needs to be
loaded.

Closes: #726797

0007 Explicitly use ruby1.9.1 for scripts.patch | (download)

bin/rmsgfmt | 2 1 + 1 - 0 !
bin/rmsginit | 2 1 + 1 - 0 !
bin/rmsgmerge | 2 1 + 1 - 0 !
bin/rxgettext | 2 1 + 1 - 0 !
4 files changed, 4 insertions(+), 4 deletions(-)

 [patch] explicitly use ruby1.9.1 for scripts