Package: ruby-gettext / 3.0.2-2~bpo70+1

0003-Do-not-use-Bundler-in-Rakefile.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
From: Hleb Valoshka <375GNU@Gmail.COM>
Date: Sun, 17 Jun 2012 16:12:33 +0300
Subject: Do not use Bundler in Rakefile

---
 Rakefile |   12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)

diff --git a/Rakefile b/Rakefile
index 77ef00e..7b5a53c 100644
--- a/Rakefile
+++ b/Rakefile
@@ -21,18 +21,8 @@ require "rubygems"
 require "yard"
 require "gettext/version"
 require "gettext/tools/task"
-require "bundler/gem_helper"
 
-class Bundler::GemHelper
-  undef_method :version_tag
-  def version_tag
-    version
-  end
-end
-
-helper = Bundler::GemHelper.new(base_dir)
-helper.install
-spec = helper.gemspec
+spec = Gem::Specification.load('gettext.gemspec')
 
 task :default => :test