Package: ruby-gravtastic / 3.2.6-2

Metadata

Package Version Patches format
ruby-gravtastic 3.2.6-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix rspec deprecated syntax.patch | (download)

Gemfile | 2 1 + 1 - 0 !
Rakefile | 2 1 + 1 - 0 !
spec/gravtastic_spec.rb | 22 11 + 11 - 0 !
3 files changed, 13 insertions(+), 13 deletions(-)

 replace rspec syntax "should" with "expect"
 `:should` syntax without explicitly enabling the syntax is deprecated in
 RSpec. This patch will replace `:should` syntax with `#expect`, which
 introduced in RSpec 2.11.
 .
 Could not forward because upstream project repository is read-only.
rr upgrade transition.patch | (download)

spec/gravtastic_spec.rb | 10 6 + 4 - 0 !
1 file changed, 6 insertions(+), 4 deletions(-)

 rr upgrade transition
 From 1.2.0, RR starts depending on RSpec 2, which also has `#stub`.
 This patch specifies `RR.stub` for using RR `#stub`.
 .
 Could not forward because upstream project repository is read-only.
apply upstream latest.patch | (download)

lib/gravtastic.rb | 21 19 + 2 - 0 !
spec/gravtastic_spec.rb | 18 11 + 7 - 0 !
2 files changed, 30 insertions(+), 9 deletions(-)

 apply the upstream latest
 Getting the upstream latest code transitions.
 .
 This patch does:
  * Add the Force Default feature and its test.
      Some time ago Gravatar launched a feature
      that allows forcing the default image to
      always load.
  * Fix the default value of attribute 'secure' to 'true'.