Package: ruby-inline / 3.12.4-2

Metadata

Package Version Patches format
ruby-inline 3.12.4-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
dont_require_rubygems | (download)

lib/inline.rb | 27 20 + 7 - 0 !
test/test_inline.rb | 13 12 + 1 - 0 !
2 files changed, 32 insertions(+), 8 deletions(-)

 calls to rubygems not allowed within the debian archive
 This module still had some RubyGems calls - This patch replaces them
 with the proper location, according to the Debian Ruby policy

fix_ruby_path | (download)

lib/inline.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use the correct location for the ruby interpreter
 Following Debian Ruby policy.

inline_mapping_instead_of_zentest_mapping | (download)

lib/inline.rb | 6 3 + 3 - 0 !
lib/inline_method_name_mapping.rb | 48 48 + 0 - 0 !
2 files changed, 51 insertions(+), 3 deletions(-)

 replaced zentestmapping usage with custom implementation
 This avoids pulling in a series of build-dependencies while allowing
 us to run the test suite

fix tests in debian build env | (download)

test/test_inline.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix test in debian build environment
ruby2.0 multiarch | (download)

lib/inline.rb | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 use proper multiarch location for ruby 2.0
no zen test.patch | (download)

metadata.yml | 14 0 + 14 - 0 !
1 file changed, 14 deletions(-)

 remove zentest from gemspec list
 it is not really needed and not packaged. Having this dependency make
 autopkgtest fail