Package: ruby-mathml / 0.14-4

Metadata

Package Version Patches format
ruby-mathml 0.14-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
fix_test_lib_import.patch | (download)

spec/math_ml_spec.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 removing relative import from spec file.
 When running adt-run, the lib dir will not be found and the test
 will fail. Once the package is installed, there is not need for
 a relative require anymore. Therefore, to fix this issue, it was
 necessary just to remove the "lib" part of the require.

 This fix will not be sent to the upstream, because the tool being used
 to hold the source code doesn't seem to allow merge requests.

fix_custom_matcher.patch | (download)

spec/util.rb | 31 14 + 17 - 0 !
1 file changed, 14 insertions(+), 17 deletions(-)

 fix custom matcher for new rspec version 3.3.0.
 The way the raise_parse_error custom matcher was defined does not
 follow the new rspec guidelines, therefore, it was necessary to
 rewrite it in order for the tests to pass.

 This fix will not be sent to the upstream, because the tool being used
 to hold the source code doesn't seem to allow merge requests.

fix_tests_for_ruby2.3.patch | (download)

spec/math_ml/element_spec.rb | 2 1 + 1 - 0 !
spec/math_ml/latex/parser_spec.rb | 8 4 + 4 - 0 !
2 files changed, 5 insertions(+), 5 deletions(-)

 fix tests for new rspec version 3.3.0
 In order for the tests to run on newer versions of rspec, same methods needs to
 be updated, such as be_false to be_falsey and be_true to be_truthy.

 This fix will not be sent to the upstream, because the tool being used
 to hold the source code doesn't seem to allow merge requests.