Package: ruby-minitest / 5.11.3-1

Metadata

Package Version Patches format
ruby-minitest 5.11.3-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
disable require rubygems | (download)

lib/minitest.rb | 2 1 + 1 - 0 !
lib/minitest/autorun.rb | 7 0 + 7 - 0 !
2 files changed, 1 insertion(+), 8 deletions(-)

 disable a require 'rubygems'.
disable some tests | (download)

test/minitest/test_minitest_reporter.rb | 2 1 + 1 - 0 !
test/minitest/test_minitest_spec.rb | 28 14 + 14 - 0 !
test/minitest/test_minitest_test.rb | 16 8 + 8 - 0 !
3 files changed, 23 insertions(+), 23 deletions(-)

 disable some broken tests
encoding | (download)

test/minitest/test_minitest_test.rb | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 force external encoding to utf-8
 some tests require UTF-8 strings whereas the default locale is C in building
 environment