Package: ruby-mkrf / 0.2.3+dfsg-5

0100_remove_rubygems.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Description: remove requirement on rubygems
Author: C├ędric Boutillier <cedric.boutillier@gmail.com>
Last-Update: 2011-12-15

--- a/lib/mkrf/generator.rb
+++ b/lib/mkrf/generator.rb
@@ -1,4 +1,3 @@
-require 'rubygems'
 require 'rbconfig'
 require 'rake/tasklib'
 
--- a/test/sample_files/cpp_bang/ext/mkrf_config.rb
+++ b/test/sample_files/cpp_bang/ext/mkrf_config.rb
@@ -1,6 +1,6 @@
-require 'rubygems'
+#require 'rubygems'
 require 'mkrf'
 
 Mkrf::Generator.new('bang', ["*.cpp"]) do |g|
   g.ldshared << ' -L/usr/lib -lgcc -lstdc++'
-end
\ No newline at end of file
+end
--- a/Rakefile
+++ b/Rakefile
@@ -3,7 +3,8 @@
 require 'rake/packagetask'
 require 'rake/gempackagetask'
 require 'rake/rdoctask'
-require 'rubygems'
+#require 'rubygems'
+
 
 $:.unshift(File.dirname(__FILE__) + "/lib")
 require 'mkrf'