Package: ruby-mocha / 0.11.3-3

Metadata

Package Version Patches format
ruby-mocha 0.11.3-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
add_rubygems_requirement.patch | (download)

lib/mocha/integration/mini_test.rb | 2 2 + 0 - 0 !
lib/mocha/integration/test_unit.rb | 2 2 + 0 - 0 !
2 files changed, 4 insertions(+)

 add requirement on rubygems
 Gem::Version is used to compare versions of the test_unit and mini_test gems.
 Defining by hand the Gem module and requiring on rubygems/requirement is
enough to have the comparisons working. 
remove_rubygems_stuff_in_minitest_test.patch | (download)

test/acceptance/minitest_test.rb | 12 6 + 6 - 0 !
1 file changed, 6 insertions(+), 6 deletions(-)

 do not rely on rubygems to load minitest