Package: ruby-mysql2 / 0.5.2-1

Metadata

Package Version Patches format
ruby-mysql2 0.5.2-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
skip random failing tests.patch | (download)

spec/mysql2/client_spec.rb | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 skip connect_attrs tests due random failure
remove_rubygems_from_examples.patch | (download)

examples/eventmachine.rb | 2 0 + 2 - 0 !
examples/threaded.rb | 1 0 + 1 - 0 !
2 files changed, 3 deletions(-)

 remove rubygems from examples
 This patch modifies the examples so that they
 do not use rubygems, and don't modify the LOAD_PATH. The
 library will be installed in a place where ruby can find it,
 and the relative path ../lib is not valid anymore.
remove_rpath_compilation_flag.patch | (download)

ext/mysql2/extconf.rb | 29 0 + 29 - 0 !
1 file changed, 29 deletions(-)

 remove rpath from compilation flags
 This patch is required to pass the binary-or-shlib-defines-rpath lintian
 test. To fix this problem, any attempt to add rpath to $LDFLAGS
 inside of ext/mysql2/extconf.rb is patched out
skip problematic tests.patch | (download)

spec/mysql2/client_spec.rb | 2 1 + 1 - 0 !
spec/mysql2/error_spec.rb | 2 1 + 1 - 0 !
2 files changed, 2 insertions(+), 2 deletions(-)

 skip problematic tests
 For some reason I cannot get these tests to pass on Debian. The first one will
 fail randomly, while the second one will always fail.
trust library ABI.patch | (download)

ext/mysql2/client.c | 18 0 + 18 - 0 !
1 file changed, 18 deletions(-)

 trust library abi
 Instead of forcibly checking MySQL client library versions, let's trust the library ABI versioning to work.