Package: ruby-nfnetlink / 1.0.2-2

001_fix-search-library.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Description: fix search library
 ffi_lib is looking for the libnfnetlink.so. We don't want to install the
 libnetlink-dev package. We modify the search to look for libnfnetlink.so.0
Author: Sophie Brun <sophie@freexian.com>
Last-Update: 2017-03-14
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/lib/nfnetlink.rb
+++ b/lib/nfnetlink.rb
@@ -39,7 +39,7 @@ module Netfilter
         extend FFI::Library
 
         begin
-            ffi_lib 'libnfnetlink'
+            ffi_lib 'libnfnetlink.so.0'
         rescue LoadError => exc
             STDERR.puts(exc.message)
             STDERR.puts "Please check that libnfnetlink is installed on your system."