Package: ruby-nokogiri / 1.10.7+dfsg1-2

Metadata

Package Version Patches format
ruby-nokogiri 1.10.7+dfsg1-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Remove warning about the version of libxml used.patch | (download)

lib/nokogiri/version.rb | 6 1 + 5 - 0 !
1 file changed, 1 insertion(+), 5 deletions(-)

 remove warning about the version of libxml used

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=546843

0002 deactivate reader_blocking test.patch | (download)

test/xml/test_reader.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 deactivate reader_blocking test

It makes the test suite hang on Debian kFreeBSD ports

https://github.com/sparklemotion/nokogiri/issues/965

0003 Remove dependency on mini_portile2.patch | (download)

Rakefile | 6 0 + 6 - 0 !
1 file changed, 6 deletions(-)

 remove dependency on mini_portile2

We don't really need it in the Debian package

Signed-off-by: Antonio Terceiro <terceiro@debian.org>

0004 Always use system libraries.patch | (download)

ext/nokogiri/extconf.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 always use system libraries

Signed-off-by: Antonio Terceiro <terceiro@debian.org>