Package: ruby-rack-mount / 0.8.3-3

Metadata

Package Version Patches format
ruby-rack-mount 0.8.3-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0003 allow conditions to duck type as a regexp alike.patch | (download)

lib/rack/mount/code_generation.rb | 17 13 + 4 - 0 !
1 file changed, 13 insertions(+), 4 deletions(-)

 allow conditions to duck-type as a regexp-alike
0001 Fix warning from Hash.patch | (download)

lib/rack/mount/route.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix warning from hash[]

  This patch will fix the following warning:
    warning: wrong element type nil at 1 (expected array)
    warning: ignoring wrong elements is deprecated, remove them explicitly
    warning: this causes ArgumentError in the next release

0002 Fix Ruby 2.0.0 compatibility.patch | (download)

lib/rack/mount/multimap.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix ruby 2.0.0 compatibility

#respond_to? now exclude protected methods.