Package: ruby-ronn / 0.7.3-3

Metadata

Package Version Patches format
ruby-ronn 0.7.3-3 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
not require rubygems | (download)

bin/ronn | 22 3 + 19 - 0 !
1 file changed, 3 insertions(+), 19 deletions(-)

 do not require rubygems
 Since this is not deployed as a ruby gem any more, requiring rubygems does not
 make sense.


use correct interpreter | (download)

test/test_ronn.rb | 20 11 + 9 - 0 !
1 file changed, 11 insertions(+), 9 deletions(-)

 use the correct interpreter in the unit tests


disable_tests_relying_on_hash_order.patch | (download)

test/test_ronn.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disable tests relying on ordered hashes
Bug: https://github.com/rtomayko/ronn/issues/56
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674380