Package: ruby-sequel / 5.42.0-1

Metadata

Package Version Patches format
ruby-sequel 5.42.0-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 specs use require instead of require relative.patch | (download)

spec/adapters/spec_helper.rb | 2 1 + 1 - 0 !
spec/core/connection_pool_spec.rb | 2 1 + 1 - 0 !
spec/core/database_spec.rb | 16 11 + 5 - 0 !
spec/core/spec_helper.rb | 4 2 + 2 - 0 !
spec/core_extensions_spec.rb | 2 1 + 1 - 0 !
spec/extensions/serialization_spec.rb | 2 1 + 1 - 0 !
spec/extensions/spec_helper.rb | 2 1 + 1 - 0 !
spec/integration/spec_helper.rb | 2 1 + 1 - 0 !
spec/model/spec_helper.rb | 2 1 + 1 - 0 !
9 files changed, 20 insertions(+), 14 deletions(-)

 specs: use 'require', instead of 'require_relative'
 Upstream uses 'require_relative' within the specs. This makes running
 the specs via autopkgtest fail, as lib/ is moved away during
 autopkgtest runs.

 This should be forwarded upstream.