Package: ruby-tty-reader / 0.7.0-2

Metadata

Package Version Patches format
ruby-tty-reader 0.7.0-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0002 bring back rspec helper.patch | (download)

.rspec | 3 3 + 0 - 0 !
1 file changed, 3 insertions(+)

 the .rspec file is missing from the released gem
 The github repository for this library contains a .rspec file that makes it
 possible to run tests on the source code. However, it is currently not
 released within the gem file published on rubygems.org. This makes it
 impossible for the debian package build process to run tests without failing.
 .
 The file content is what can currently be found in the git repository for tag
 0.7.0
 .
 ruby-tty-reader (0.7.0-1) UNRELEASED; urgency=medium
 .
   * Initial release (Closes: #941403)
0001 drop bundler.patch | (download)

spec/spec_helper.rb | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 drop bundler
0003 spec helper missing require.patch | (download)

spec/spec_helper.rb | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 the test suite refuses to run with ruby 2.7
 Without this require line, ruby 2.7 fails to run the test suite. When the
 "class StringIO" line is encountered, since the class is not defined, a new
 class that inherits from Object is created and the majority of the expected
 interface is missing.
 .
 This used to work in ruby 2.5 without the require line.
 .
 Upstream has already fixed this but the fix has yet to be released in a new
 version.