Package: shiboken / 1.2.2-1

Metadata

Package Version Patches format
shiboken 1.2.2-1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
cmake_selectDefaultPython.patch | (download)

data/ShibokenConfig.cmake.in | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 use the _default_ python version as fallback default.
pythonversionindep.patch | (download)

cmake/Modules/FindPython3Interp.cmake | 3 3 + 0 - 0 !
cmake/Modules/FindPython3Libs.cmake | 4 2 + 2 - 0 !
cmake/Modules/FindPythonInterpWithDebug.cmake | 2 1 + 1 - 0 !
3 files changed, 6 insertions(+), 3 deletions(-)

 allow the packaging definitions to pick the desired python version and compilation flags in both python2 and python3.
python3.3 and multiarch.patch | (download)

cmake/Modules/FindPython3Libs.cmake | 10 9 + 1 - 0 !
1 file changed, 9 insertions(+), 1 deletion(-)

---
python3.3 nolong.patch | (download)

tests/samplebinding/overflow_test.py | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 pep-0237 deprecated long( in favour of the old int(.
memleak instead crash.patch | (download)

libshiboken/basewrapper.cpp | 2 1 + 1 - 0 !
tests/samplebinding/objecttype_test.py | 2 1 + 1 - 0 !
tests/samplebinding/ownership_delete_parent_test.py | 8 4 + 4 - 0 !
3 files changed, 6 insertions(+), 6 deletions(-)

 exchange crash with a memleak
 the code in question looks horrible, it dereferences an object and keeps
 using it, but thats not even the cause of the crash.
 Intentionally add memleak which is better than crashing in all python
 versions for now.
Bug: https://bugreports.qt-project.org/browse/PYSIDE-121
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/shiboken/+bug/1070772
fix_py3_expect.patch | (download)

tests/minimalbinding/typedef_test.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix the except syntax to be python3-compatible, pep-3110
pkg config depend on python.patch | (download)

data/shiboken.pc.in | 5 3 + 2 - 0 !
1 file changed, 3 insertions(+), 2 deletions(-)

 drop the explicit dependencies of libs and cflags in pkg-config in favour of a versioned requires.