Package: simplesamlphp / 1.14.11-1+deb9u1

CVE-2018-6521.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
diff -ur simplesamlphp-1.13.1.orig/modules/sqlauth/lib/Auth/Source/SQL.php simplesamlphp-1.13.1/modules/sqlauth/lib/Auth/Source/SQL.php
--- simplesamlphp-1.13.1.orig/modules/sqlauth/lib/Auth/Source/SQL.php	2014-10-27 16:28:10.000000000 +0100
+++ simplesamlphp-1.13.1/modules/sqlauth/lib/Auth/Source/SQL.php	2018-03-01 19:53:19.699253337 +0100
@@ -95,7 +95,7 @@
 		switch ($driver) {
 		case 'mysql':
 			/* Use UTF-8. */
-			$db->exec("SET NAMES 'utf8'");
+			$db->exec("SET NAMES 'utf8mb4'");
 			break;
 		case 'pgsql':
 			/* Use UTF-8. */