Package: smart-notifier / 0.28-5

Metadata

Package Version Patches format
smart-notifier 0.28-5 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Audit the D Bus security policy file.patch | (download)

config/smart-notifier.conf | 9 1 + 8 - 0 !
1 file changed, 1 insertion(+), 8 deletions(-)

 audit the d-bus security policy file

Audit the D-Bus security policy file for compatibility with D-Bus versions where
CVE-2008-4311 has been fixed, and remove rules that appear to have been
cargo-culted from some other package and are likely to cause unintended
consequences for other packages (see freedesktop.org #18961).

0002 Only display SMART messages from root.patch | (download)

src/smart_notifier/gui.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 only display smart messages from root

Only display the SMART message if it came from the part of smart_notifier
that only root can run, rather than allowing arbitrary local users to
spoof arbitrary messages from smartd. (Closes: #510709)

0003 Use one smart_notify directory.patch | (download)

scripts/smart-notifier | 5 1 + 4 - 0 !
1 file changed, 1 insertion(+), 4 deletions(-)

 use one smart_notify directory

Instead of installing one copy of smart_notify for every python version, only
install one copy for all

0004 Don t capitalize false in .desktop file.patch | (download)

config/smart-notifier.desktop | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 don't capitalize false in .desktop file

Closes: #512684, #550993

0005 Remove useless cat in 60smart notifier.patch | (download)

scripts/60smart-notifier | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 remove useless cat in 60smart-notifier

Closes: #511504

0006 Use positional parameters in add_signal_receiver.patch | (download)

src/smart_notifier/gui.py | 8 4 + 4 - 0 !
1 file changed, 4 insertions(+), 4 deletions(-)

 use positional parameters in add_signal_receiver()

named_service was deprecated, and judging by the warning from dbus, calling the
function using named parameters is not supported.

Closes: #545265

0007 Switch to GtkBuilder.patch | (download)

setup.py | 2 1 + 1 - 0 !
src/smart_notifier/gui.py | 14 7 + 7 - 0 !
src/smart_notifier/smart-notifier.xml | 127 127 + 0 - 0 !
3 files changed, 135 insertions(+), 8 deletions(-)

 switch to gtkbuilder


0008 Port to gtk3 Use gi.repository.Gtk.patch | (download)

src/smart_notifier/gui.py | 12 6 + 6 - 0 !
1 file changed, 6 insertions(+), 6 deletions(-)

 port to gtk3 (use gi.repository.gtk)


0009 Make notification window resizable.patch | (download)

src/smart_notifier/smart-notifier.xml | 4 1 + 3 - 0 !
1 file changed, 1 insertion(+), 3 deletions(-)

 make notification window resizable

Also drop default width/height, as it is too big, and allow expander to resize
the toplevel window when collapsing.

Closes: #374719

0010 Update deprecated import dbus.glib.patch | (download)

src/smart_notifier/__init__.py | 7 4 + 3 - 0 !
1 file changed, 4 insertions(+), 3 deletions(-)

 update deprecated 'import dbus.glib'

'import dbus.glib' is deprecated as the API is extremely unintuitive. As
recommended by the documentation by the deprecated dbus.glib module, replace
this by a call to DBusGMainLoop(set_as_default=True)