Package: snapd / 2.30-5

Metadata

Package Version Patches format
snapd 2.30-5 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
disable i18n.patch | (download)

i18n/i18n.go | 81 1 + 80 - 0 !
i18n/i18n_test.go | 162 0 + 162 - 0 !
tests/main/i18n/task.yaml | 26 0 + 26 - 0 !
3 files changed, 1 insertion(+), 268 deletions(-)

 disable i18n
 The i18n support in snapd depends on a package that has not yet been packaged.
 Disable for now until we get the ITP done.
disable seccomp tests.patch | (download)

cmd/snap-seccomp/export_test.go | 2 2 + 0 - 0 !
cmd/snap-seccomp/main_test.go | 2 2 + 0 - 0 !
2 files changed, 4 insertions(+)

 disable cmd/snap-seccomp tests
 The snap-seccomp tests require a fork of the golang/x/net library to run.
 Disable the tests until the necessary changes are upstream.
no seccomp fork.patch | (download)

cmd/snap-seccomp/main.go | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 do not use a fork of github.com/seccomp/libseccomp-golang
 Upstream uses a fork of this library so it can work on Ubuntu 14.04. The
 Debian package does not have to care about this so we can just use the
 version from the archive.
disable TestDoRequestSerialErrorsOnNoHost.patch | (download)

overlord/devicestate/devicestate_test.go | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

---
fix pkg config line.patch | (download)

cmd/snap-seccomp/main.go | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

 fix ftbfs