Package: sollya / 6.0+ds-1

debianization.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Description: debianization
 Meant to maintain a minimal debian/rules, to fix annoying
 warnings, to address Debian specific stuff in general.
Author: Jerome Benoit <calculus@rezozer.net>
Last-Update: 2016-10-17

--- a/configure.ac
+++ b/configure.ac
@@ -358,8 +358,8 @@
 AC_CHECK_LIB([mpfr], [mpfr_set_z_2exp], [true], AC_MSG_ERROR([libmpfr version too old]))
 AC_CHECK_LIB([mpfr], [mpfr_erfc], [], AC_MSG_ERROR([libmpfr version too old])) # This one adds -lmpfr in case of success
 AC_CHECK_LIB([mpfi], [mpfi_init], [], AC_MSG_ERROR([libmpfi unusable]))
-AC_CHECK_LIB([z], [gzdopen], [], [])
-AC_CHECK_LIB([iconv], [libiconv_open], [], []) # This for providing a statically linked program under Cygwin. See e0d7171f9daf0027e075723d21fb40a864578cd5
+####AC_CHECK_LIB([z], [gzdopen], [], [])
+####AC_CHECK_LIB([iconv], [libiconv_open], [], []) # This for providing a statically linked program under Cygwin. See e0d7171f9daf0027e075723d21fb40a864578cd5
 AC_CHECK_LIB([m],[cos])
 AC_CHECK_LIB([xml2], [xmlTextReaderIsEmptyElement], [], AC_MSG_ERROR([libxml2 unusable]))