Package: spice / 0.12.8-2.1+deb9u3

stop-linking-with-libcacard.diff Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
Subject: do not link spice with libcacard
From: Michael Tokarev <mjt@tls.msk.ru>
Submitted-Upstream: yes

None of the libcacard symbols are actually used by the library,
only the header files, so there's no need to link with libcacard.

Signed-off-by: Michael Tokarev <mjt@tls.msk.ru>

--- a/configure.ac
+++ b/configure.ac
@@ -105,9 +105,9 @@
 
 SPICE_REQUIRES=""
 
-AS_IF([test x"$have_smartcard" = "xyes"], [
-    AS_VAR_APPEND([SPICE_REQUIRES], [" libcacard >= 0.1.2"])
-])
+dnl AS_IF([test x"$have_smartcard" = "xyes"], [
+dnl     AS_VAR_APPEND([SPICE_REQUIRES], [" libcacard >= 0.1.2"])
+dnl ])
 
 SPICE_PROTOCOL_MIN_VER=0.12.10
 PKG_CHECK_MODULES([SPICE_PROTOCOL], [spice-protocol >= $SPICE_PROTOCOL_MIN_VER])