Package: stompserver / 0.9.9gem-4

Metadata

Package Version Patches format
stompserver 0.9.9gem-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
remove_rubygems.patch | (download)

bin/stompserver | 1 0 + 1 - 0 !
lib/stomp_server.rb | 1 0 + 1 - 0 !
lib/stomp_server/test_server.rb | 1 0 + 1 - 0 !
3 files changed, 3 deletions(-)

 remove requirement of rubygems
# Requiring RubyGems is discouraged by the Debian Ruby Extras team
# per http://pkg-ruby-extras.alioth.debian.org/upstream-devs.html
fhs_paths.patch | (download)

lib/stomp_server.rb | 11 6 + 5 - 0 !
1 file changed, 6 insertions(+), 5 deletions(-)

 check for absolute paths so we can enforce fhs in config.
# No upstream patch/URL yet, will update package when one is open.
fix_storagedir.patch | (download)

lib/stomp_server/queue/activerecord_queue.rb | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 bug in initialize won't create the storage dir in fhs compliant location
# No upstream bug yet, will update the package when there is one.
ruby19_20.patch | (download)

lib/stomp_server/stomp_frame.rb | 6 3 + 3 - 0 !
test/test_topic_manager.rb | 2 1 + 1 - 0 !
2 files changed, 4 insertions(+), 4 deletions(-)

 [patch] adapt for ruby 1.9
ruby_hashbang.patch | (download)

bin/stompserver | 2 2 + 0 - 0 !
1 file changed, 2 insertions(+)

 added shebang into bin/stompserver