Package: sushi / 1.4.0+git20160822+dfsg-4

Metadata

Package Version Patches format
sushi 1.4.0+git20160822+dfsg-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
maki revert 3bb2b23.diff | (download)

maki/source/plugins/upnp.c | 3 1 + 2 - 0 !
maki/wscript | 34 16 + 18 - 0 !
2 files changed, 17 insertions(+), 20 deletions(-)

 revert upstream maki commit 3bb2b23 and re-enable gupnp
#  support as gupnp deadlock was fixed time ago.
# gupnp bug report:
#  https://bugzilla.gnome.org/show_bug.cgi?id=667494
# upstream commit:
#  https://github.com/sushi-irc/maki/commit/3bb2b239c1904f9373d0bf8250ae451cad70d647
nigiri 00 fix gobject import.diff | (download)

nigiri/main.py.in | 4 2 + 2 - 0 !
nigiri/plugin_control.py | 2 1 + 1 - 0 !
2 files changed, 3 insertions(+), 3 deletions(-)

 fix following importerror error:
#  ImportError: When using gi.repository you must not import static modules
#  like "gobject". Please change all occurrences of "import gobject" to
#  "from gi.repository import GObject".
#  See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
nigiri 01 fix urwid indexerror.diff | (download)

nigiri/extends/ListBox.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix following indexerror error:
#  IndexError: No widget at position 1
nigiri 02 none has no auto_scroll.diff | (download)

nigiri/main.py.in | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 fix following attributeerror error:
#  AttributeError: 'NoneType' object has no attribute 'auto_scroll'