Package: sympa / 6.1.11~dfsg-5+deb7u2

Metadata

Package Version Patches format
sympa 6.1.11~dfsg-5+deb7u2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001_fix_cas_authentication.patch | (download)

wwsympa/Auth.pm | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix cas/ldap authentication
0002_fix_web_interface_vulnerability | (download)

wwsympa/wwsympa.fcgi.in | 11 8 + 3 - 0 !
1 file changed, 8 insertions(+), 3 deletions(-)

 fix a vulnerability in the web interface (wwsympa)
 which allows one to send himself by email any readable file by the
 sympa user on the filesystem
1002_mysql_default_charset_engine.patch | (download)

src/etc/script/create_db.mysql | 24 12 + 12 - 0 !
1 file changed, 12 insertions(+), 12 deletions(-)

 add default charset and engine to mysql schema
1004_wizard_support_batch_and_display_mode.patch | (download)

src/sympa_wizard.pl.in | 48 46 + 2 - 0 !
1 file changed, 46 insertions(+), 2 deletions(-)

 add batch and display modes to sympa_wizard.pl
1005_wizard_emit_cmd_and_newline_when_dying.patch | (download)

src/sympa_wizard.pl.in | 12 6 + 6 - 0 !
1 file changed, 6 insertions(+), 6 deletions(-)

 emit command name and newline when dying in sympa_wizard.pl
1006_wizard_add_soap_url_and_archive_default_index.patch | (download)

src/lib/confdef.pm | 13 13 + 0 - 0 !
1 file changed, 13 insertions(+)

 add soap_url and archive_default_index support to sympa_wizard.pl
1007_wizard_probe_currently_supported_locales.patch | (download)

src/sympa_wizard.pl.in | 45 45 + 0 - 0 !
1 file changed, 45 insertions(+)

 probe currently supported locales in sympa_wizard.pl
1010_db_port.patch | (download)

src/lib/confdef.pm | 3 2 + 1 - 0 !
1 file changed, 2 insertions(+), 1 deletion(-)

 disable mysql default port.
1011_fix_sqlite_db_upgrade | (download)

src/etc/script/create_db.SQLite | 90 49 + 41 - 0 !
src/lib/Upgrade.pm | 195 130 + 65 - 0 !
2 files changed, 179 insertions(+), 106 deletions(-)

 fix sqlite db schema upgrade
1012_fix_manpages_typos_and_whatis_entries.patch | (download)

doc/man8/alias_manager.pod.in | 2 1 + 1 - 0 !
doc/man8/archived.pod.in | 4 2 + 2 - 0 !
doc/man8/bounced.pod.in | 2 1 + 1 - 0 !
doc/man8/sympa.pod | 2 1 + 1 - 0 !
4 files changed, 5 insertions(+), 5 deletions(-)

 fix typos and bad whatis entries in manpages
1013_fix_wording_sympa_wizard_manpage.patch | (download)

src/sympa_wizard.pl.in | 10 5 + 5 - 0 !
1 file changed, 5 insertions(+), 5 deletions(-)

 fix some wording in sympa_wizard manpage
1014_fix_unknown_parameter_ldap_force_canonical_email.patch | (download)

wwsympa/wwslib.pm | 1 1 + 0 - 0 !
1 file changed, 1 insertion(+)

 fix warnings in logs about 'unknown parameter ldap_force_canonical_email'
2001_ca_bundle_check_as_warning.patch | (download)

src/lib/Conf.pm | 6 5 + 1 - 0 !
1 file changed, 5 insertions(+), 1 deletion(-)

 raise a warning instead of an error when the ca bundle file is not readable.
  For its internal usage (to make https request and verify smime mail signatures) Sympa
  needs access to the Certificates Authorities installed on the system.

  Certificates Authorities are available in the package ca-certificates and
  this package also provides a single file with all the CA concatenated.
  The location of this file is /etc/ssl/certs/ca-certificates.crt

  Sympa package provides a symlink from /usr/share/sympa/default/ca-bundle.crt
  to /etc/ssl/certs/ca-certificates.crt

  Recently, to fix bug #537051 the ca-certificates package maintainer has
  decided to replace the CA bundle generation
  (/etc/ssl/certs/ca-certificates.crt) in the postinst by a trigger.

  During installation of Sympa, if ca-certificates is not present, it is
  installed as a Sympa dependency but the sympa postinst will always be
  executed before the ca-certificates triggers.
  It means that Sympa start will fail with an error because
  /etc/ssl/certs/ca-certificates.crt does not exists (not yet generated by the
  ca-certificates trigger).

  The following patch tries to detect if the CA bundle configured in sympa is a
  symlink to /etc/ssl/certs/ca-certificates.crt. In that case, a warning raised
  instead of en error.

  This is a purely Debian specific fix, which is quite ugly but it works.

  A better patch will be very much appreciated.
2002_wizard_drop_localedir.patch | (download)

src/lib/confdef.pm | 6 0 + 6 - 0 !
1 file changed, 6 deletions(-)

 drop localedir support in sympa_wizard.pl
2004_pg_create_db.patch | (download)

src/etc/script/create_db.Pg | 16 0 + 16 - 0 !
1 file changed, 16 deletions(-)

 postgresql database creation script improvements.
2005_disable_build_non_dfsg_po_files.patch | (download)

po/LINGUAS | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 disable build of non dfsg po files (it.po and oc.po)
2006_disable_cssupdated_email_on_update.patch | (download)

src/lib/Conf.pm | 6 3 + 3 - 0 !
1 file changed, 3 insertions(+), 3 deletions(-)

 disable email notification 'css updated' on each upgrade
2007_fix_CVE 2012 2352.patch | (download)

wwsympa/wwsympa.fcgi.in | 4 4 + 0 - 0 !
1 file changed, 4 insertions(+)

 properly fix cve-2012-2352
2008_add_missing_webtt2_helpsuspend.patch | (download)

web_tt2/Makefile.am | 1 1 + 0 - 0 !
web_tt2/Makefile.in | 1 1 + 0 - 0 !
web_tt2/help_suspend.tt2 | 18 18 + 0 - 0 !
3 files changed, 20 insertions(+)

 add missing template help_suspend.tt2