Package: system-config-printer / 1.5.11-4

Metadata

Package Version Patches format
system-config-printer 1.5.11-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0006 use paper size default in etc papersize.patch | (download)

cupshelpers/cupshelpers.py | 17 17 + 0 - 0 !
1 file changed, 17 insertions(+)

 use setting in /etc/papersize if available

Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=593219
0007 fix pk package name.patch | (download)

newprinter.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix the package names that packagekit should try to install

0003 Use ValueError instead of ImportError to catch excep.patch | (download)

jobviewer.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 use valueerror instead of importerror to catch exception when
 importing GIR bindings

When importing specific version of GIR bindings, the ValueError
exception is raised instead of ImportError.

This should make libsecret optional as intended

Fixes: #94

0004 Fix constructing the auth dialog.patch | (download)

authconn.py | 2 0 + 2 - 0 !
1 file changed, 2 deletions(-)

 fix constructing the auth dialog

47973c80 (Remove deprecated Gtk objects) broke the auth dialog.

Fixes https://bugs.archlinux.org/task/57364.

0005 Require proper version of GDK and GTK in scp dbus se.patch | (download)

scp-dbus-service.py | 3 3 + 0 - 0 !
1 file changed, 3 insertions(+)

 require proper version of gdk and gtk in scp-dbus-service as well

scp-dbus-service can be D-Bus activated, that means that
gi.require_version() is not called before.

That needs to be kept in sync with the required version in the main
program file.

0006 Set programe name for scp dbus service as well.patch | (download)

scp-dbus-service.py | 5 4 + 1 - 0 !
1 file changed, 4 insertions(+), 1 deletion(-)

 set programe name for scp-dbus-service as well

scp-dbus-service can be D-Bus activated, that means that the program
name is never set meaning that the icon and the fancy name in the window
list is never set.

This completes the fix for bug #53

define classes for Secret only when libsecret is installe.patch | (download)

jobviewer.py | 123 62 + 61 - 0 !
1 file changed, 62 insertions(+), 61 deletions(-)

 define classes for secret only when libsecret is installed
 (https://github.com/zdohnal/system-config-printer/issues/118,
 https://github.com/zdohnal/system-config-printer/issues/115)