Package: system-config-printer / 1.5.11-4

0004-Fix-constructing-the-auth-dialog.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Thu, 8 Feb 2018 17:01:01 +0100
Subject: Fix constructing the auth dialog

47973c80 (Remove deprecated Gtk objects) broke the auth dialog.

Fixes https://bugs.archlinux.org/task/57364.
---
 authconn.py | 2 --
 1 file changed, 2 deletions(-)

diff --git a/authconn.py b/authconn.py
index 2a645dc..0f3021c 100644
--- a/authconn.py
+++ b/authconn.py
@@ -78,11 +78,9 @@ class AuthDialog(Gtk.Dialog):
             field = auth_info_required[i]
             label = Gtk.Label (label=_(self.AUTH_FIELD.get (field, field)))
             label.set_alignment (0, 0.5)
-            grid.attach (label, 0, 1, i, i + 1)
             grid.attach (label, 0, i, 1, 1)
             entry = Gtk.Entry ()
             entry.set_visibility (field != 'password')
-            grid.attach (entry, 1, 2, i, i + 1, 0, 0)
             grid.attach (entry, 1, i, 1, 1)
             self.field_entry.append (entry)