Package: transmission / 2.94-2

ayatana-indicators.patch Patch series | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Date: Sun, 6 May 2018 15:35:38 -0400
Subject: Build against Ayatana AppIndicator

---
 configure.ac  | 4 ++--
 gtk/tr-icon.c | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/configure.ac b/configure.ac
index 9b19ae7..9331c47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -526,7 +526,7 @@ if test "x$with_gtk" = "xyes" ; then
                               gmodule-2.0 >= $GLIB_MINIMUM
                               gthread-2.0 >= $GLIB_MINIMUM])
     PKG_CHECK_MODULES([LIBAPPINDICATOR],
-                      [appindicator3-0.1 >= $LIBAPPINDICATOR_MINIMUM],
+                      [ayatana-appindicator3-0.1 >= $LIBAPPINDICATOR_MINIMUM],
                       [have_libappindicator=yes],
                       [have_libappindicator=no])
     if test "x$have_libappindicator" = "xyes"; then
@@ -690,7 +690,7 @@ Configuration:
    Build Command-Line client:                         ${build_cli}
 
    Build GTK+ client:                                 ${with_gtk}
-      * libappindicator for an Ubuntu-style tray:     ${use_libappindicator}
+      * libayatana-appindicator for Ubuntu-like tray: ${use_libappindicator}
 
    Build Daemon:                                      ${build_daemon}
 
diff --git a/gtk/tr-icon.c b/gtk/tr-icon.c
index a8911b8..a4c5c02 100644
--- a/gtk/tr-icon.c
+++ b/gtk/tr-icon.c
@@ -11,7 +11,7 @@
 #include <glib/gi18n.h>
 #include <gtk/gtk.h>
 #ifdef HAVE_LIBAPPINDICATOR
- #include <libappindicator/app-indicator.h>
+ #include <libayatana-appindicator/app-indicator.h>
 #endif
 #include <libtransmission/transmission.h>
 #include <libtransmission/utils.h>