Package: uw-imap / 8:2007f~dfsg-6

Metadata

Package Version Patches format
uw-imap 8:2007f~dfsg-6 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
1001_shlibs.patch | (download)

Makefile | 8 7 + 1 - 0 !
src/dmail/Makefile | 7 2 + 5 - 0 !
src/imapd/Makefile | 4 2 + 2 - 0 !
src/ipopd/Makefile | 4 2 + 2 - 0 !
src/mailutil/Makefile | 7 2 + 5 - 0 !
src/mtest/Makefile | 7 2 + 5 - 0 !
src/osdep/unix/Makefile | 20 17 + 3 - 0 !
src/tmail/Makefile | 7 2 + 5 - 0 !
8 files changed, 36 insertions(+), 28 deletions(-)

---
1002_fix_ftbfs.patch | (download)

src/osdep/unix/flocklnx.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
1003_fix_zero_len_when_mail_fetch_body_is_empty.patch | (download)

src/c-client/mail.c | 5 4 + 1 - 0 !
1 file changed, 4 insertions(+), 1 deletion(-)

 properly zero out len when mail_fetch_body() returns an empty string
1004_support_rfc5464_METADATA.patch | (download)

src/c-client/imap4r1.c | 181 180 + 1 - 0 !
src/c-client/imap4r1.h | 2 2 + 0 - 0 !
src/c-client/mail.c | 33 33 + 0 - 0 !
src/c-client/mail.h | 24 24 + 0 - 0 !
src/mtest/mtest.c | 38 37 + 1 - 0 !
5 files changed, 276 insertions(+), 2 deletions(-)

 implement support for imap extension metadata (rfc5464)
 Provides get/set ANNOTATIONS support to the c-client library.
 .
 [Version: 2006j2]
2002_mailspool.patch | (download)

src/osdep/unix/Makefile | 4 2 + 2 - 0 !
1 file changed, 2 insertions(+), 2 deletions(-)

---
2004_no_binaries_below_etc.patch | (download)

src/imapd/imapd.8 | 4 2 + 2 - 0 !
src/ipopd/ipopd.8 | 4 2 + 2 - 0 !
src/osdep/unix/tcp_unix.c | 4 2 + 2 - 0 !
3 files changed, 6 insertions(+), 6 deletions(-)

---
2010_disallow_escaping_home.patch | (download)

src/osdep/unix/env_unix.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---
2011_disable_version_check.patch | (download)

src/c-client/mail.c | 9 2 + 7 - 0 !
1 file changed, 2 insertions(+), 7 deletions(-)

 disable version check
 The version check in mail_versioncheck(), called via #include "linkage.c",
 Prevents new versions of the shared library to be used without rebuilding
 all applications, even if there wouldn't be any other problems doing so.
 Package dependencies, SONAME, and Debian's build system make sure that
 a compatible version will be loaded; therefore we remove this check.
2012_krb5_multidev.patch | (download)

src/osdep/unix/Makefile | 6 3 + 3 - 0 !
src/osdep/unix/Makefile.gss | 4 2 + 2 - 0 !
2 files changed, 5 insertions(+), 5 deletions(-)

 depend on krb5-multidev rather than libkrb5-dev.
Bug-Debian: https://bugs.debian.org/745333
1005_poll.patch | (download)

src/osdep/unix/os_lnx.c | 1 1 + 0 - 0 !
src/osdep/unix/os_slx.c | 1 1 + 0 - 0 !
src/osdep/unix/tcp_unix.c | 78 26 + 52 - 0 !
3 files changed, 28 insertions(+), 52 deletions(-)

 use poll(2) instead of select(2) to support more than 1024 file descriptors
1006_openssl1.1_autoverify.patch | (download)

src/osdep/unix/ssl_unix.c | 14 13 + 1 - 0 !
1 file changed, 13 insertions(+), 1 deletion(-)

 support openssl 1.1
 When building with OpenSSL 1.1 and newer, use the new built-in
 hostname verification instead of code that doesn't compile due to
 structs having been made opaque.
Bug-Debian: https://bugs.debian.org/828589


2013_disable_rsh.patch | (download)

src/osdep/unix/Makefile | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

---