Package: wireguard / 1.0.20210223-1~bpo10+1

Metadata

Package Version Patches format
wireguard 1.0.20210223-1~bpo10+1 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
0001 Avoid using git during build.patch | (download)

src/Makefile | 4 0 + 4 - 0 !
1 file changed, 4 deletions(-)

 avoid using git during build


0002 Avoid requiring glibc 2.25 for wireguard tools.patch | (download)

src/genkey.c | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 avoid requiring glibc 2.25 for wireguard-tools

Upstream's instructions (https://www.wireguard.com/install/) suggest
enabling the debian unstable repository to run wireguard.

Without this patch, the current version of wireguard-tools will end up
with a dependency on glibc 2.25 because of the invocation of
getentropy.

We avoid this situation (and fall through to the syscall interface
for the Linux kernel) by omitting the test here.

If we move wireguard into testing (and from there to
stretch-backports) then i think we can convince upstream to change
their installation instructions to refer to stretch-backports, and we
can remove this patch.