Package: wss4j / 1.6.19-2

Metadata

Package Version Patches format
wss4j 1.6.19-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
01 no saml.patch | (download)

pom.xml | 10 10 + 0 - 0 !
src/main/java/org/apache/ws/security/WSSConfig.java | 6 6 + 0 - 0 !
src/main/java/org/apache/ws/security/WSSecurityEngineResult.java | 3 2 + 1 - 0 !
src/main/java/org/apache/ws/security/processor/BinarySecurityTokenProcessor.java | 4 2 + 2 - 0 !
src/main/java/org/apache/ws/security/processor/UsernameTokenProcessor.java | 4 2 + 2 - 0 !
src/main/java/org/apache/ws/security/str/BSPEnforcer.java | 3 2 + 1 - 0 !
src/main/java/org/apache/ws/security/str/DerivedKeyTokenSTRParser.java | 5 2 + 3 - 0 !
src/main/java/org/apache/ws/security/str/EncryptedKeySTRParser.java | 8 4 + 4 - 0 !
src/main/java/org/apache/ws/security/str/SecurityTokenRefSTRParser.java | 10 6 + 4 - 0 !
src/main/java/org/apache/ws/security/str/SignatureSTRParser.java | 15 10 + 5 - 0 !
src/main/java/org/apache/ws/security/validate/Credential.java | 11 8 + 3 - 0 !
11 files changed, 54 insertions(+), 25 deletions(-)

 saml is not packaged in debian yet (rfp #656541).
 This patch disables the compilation of the SAML related code.