Package: yowsup / 2.5.7-4

Metadata

Package Version Patches format
yowsup 2.5.7-4 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
00 fix python37 compat.patch | (download)

yowsup/demos/cli/layer.py | 2 1 + 1 - 0 !
yowsup/layers/interface/interface.py | 2 1 + 1 - 0 !
yowsup/layers/protocol_media/mediauploader.py | 7 4 + 3 - 0 !
3 files changed, 6 insertions(+), 5 deletions(-)

 fix compatibility with python 3.7 since async has become a reserved word
00 fix protocol tree node import.patch | (download)

yowsup/layers/protocol_media/picture.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 fix wrong import for protocoltreenode
00 disable setup tools dependency.patch | (download)

setup.py | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 disables check of build dependencies at build time.
00 fix data installation path.patch | (download)

setup.py | 2 1 + 1 - 0 !
yowsup/common/tools.py | 4 3 + 1 - 0 !
2 files changed, 4 insertions(+), 2 deletions(-)

 fixes wrong installation of mime.types file.
00 fix compat six.patch | (download)

yowsup/env/env.py | 1 0 + 1 - 0 !
1 file changed, 1 deletion(-)

 removes __metaclass__ keyword since its use breaks its compatibility with python-six >= 1.11